ウイルス対策ソフトをご利用の場合、「トロイの木馬」を誤検出する記事があります。警告が出た際は、こちらの記事をごらんの上、お知らせいただければ幸いです。

« それは世間によくある誤解。乾電池編。 | トップページ | またもやStop:0x00000024。今度はierdfgh.exeとセット。 »

2009年4月17日 (金)

この「つながらない」は…。

このエントリーをはてなブックマークに追加 このエントリーを含むはてなブックマーク この記事をクリップ! BuzzurlにブックマークBuzzurlにブックマーク

こちらは「インターネットにつながらなくなりました」というお客様。
パソコンは、WindowsXPのデスクトップ機。
なんでも、ソニーのウォークマンのソフトをインストールに失敗してからダメになったとか。
とにかくお伺いです。

現象確認してみたところ…どうもおかしい。

ネットはYBBの白モデムで、無線LANにも対応してますが、有線接続はブリッジ接続のタイプ。
「ローカルエリア接続」を確認したら、とりあえずIPアドレスは取れている。
「修復」ボタンでIPアドレスの取り直しはできるので、決してつながっていないわけではない。
でも…つながらないのだ。
IEを開いても、「ページが表示できません」です。

ここで真っ先に考えられるのは…。

2007年5月15日 (火) メールは使えるのにホームページが見れません。
2005年11月12日 (土) またつながらない!

IEが拒否られているというありがちな話。
これならメールは使えるはずですからわかりやすい。

「いえ、メールもダメなんですよ」

…そ、そうですか…。
実際、使えませんでした…。

と、いうことは…DNSの解決ができてない?

Lesson1:ドメイン名とIPアドレスを結ぶ,DNSの役割を確認する :ITpro 日経NETWORK

たとえば、私のサイトはアドレス欄に「http://pcdoc.jp/」と入力すれば表示されますが、実際には、「***.***.***.***」といった、0~255の数字4つを組み合わせたIPアドレスへの変換が必要で、それをするのがDNSです。

たとえばここで、この問題のパソコンに、「pcdoc.jp」などの代わりに、それに該当するIPアドレスを入力しても、一応サイト表示はされます。
ただ、画像などはIPアドレスで参照していないので、表示できないものも出てきます。
ということで、「インターネットにつながっていない」というわけではなく、「DNSが利用できないだけ」とわかります。

実を言うと、お客様にはお伺い前にYBBへ連絡してもらって、回線には問題がないことを確認済みなのです。
持ってきたメンテ用パソコンに差し替えると、IPアドレスの取得はできて、ブラウザ表示は何の問題も無くできます。
ということは…うーむ…。

-----

単純にIPアドレスが取れないのであれば、それはそれでアプローチがあるし、その方が問題をつかみやすい。
でも今回は、IPアドレスは取れて接続はできているものの、DNSが使えない、という症状。
DNSが使えないのは、いろんな理由がありますが、今回は同じモデムにつないで、同じくグローバルアドレスが取れる状態で、別のパソコンでは問題なく使えるところを考えると、明らかにパソコン側の問題。

とりあえず問題のあったウォークマンのソフトをインストールした前の段階へ「システムの復元」をやってみましたが、やっぱりダメ。

…うーむむむむむむむ。

で、さっきから気になってたのは、タスクトレイの古いノートンのアイコン。
パソコンの頭にアンテナが付いてぴこぴこしている、2006年版あたりのLiveUpdateのアイコン。アレです。
(今回は画面キャプチャを撮り損ねてしまいました…)
どう考えても、コレは古すぎるでしょう…また期限切れノートンが悪さしてる?

2008年12月18日 (木) そろそろエラーコードを何とかしてほしい。

もうね、期限切れノートンはね、ろくなことがないですね。

「え?毎月ちゃんと払ってるはずですけど…」

…は、はいぃ?

ノートンのメイン画面を開いてみたら…「BBセキュリティ Powerd by Symantec」の文字が。
あちゃ~…月額版の弱点ですね。

月額版で期限切れがないと言っても、ほったらかしではダメで、エンジンの更新は毎年手動でやらなければなりません…。

ウイルスセキュリティZEROの場合は、コレがないので、私はお勧めしてるんですが、残念ながら常に在庫を常備しているわけではないのと、月額版はクレジットカード番号の打ち込みが必要なくて支払い手続きが楽なのと、お客様の好みの問題もあるので、プロバイダの月額版のノートンやバスターを入れる場合が結構多いです。
ただ、月額版の場合は、放置でいいと思い込んでいると、こんな具合に、数年後に問題が顕在化してきます。

とにかくこれでは入っていても意味がないので、とにかくアンインストール。
余計なトラブルの回避の意味で、Norton 削除ツール (Norton Removal Tool)を最初から使いました。

Norton 削除ツール (Norton Removal Tool) を使う方法 - 詳細手順

途中でなぜか画面表示の文字を入力させるステップがありますが、これはどうやら、悪意のあるソフトによる自動実行でノートン自体を削除してしまうことを防ぐ意味があるらしいです。

Nortonを完全アンインストールする :Hibi日記

こちらの記事のコメント欄を参照。

要は「人間が操作してますか?」という確認ですね。

ということで、ノートン先生さようなら~をしたのですが…やっぱりダメです。DNS参照が全くできてません。
コマンドプロンプトからURLでのPINGも通りませんし、完全にDNSへの接続の問題ですね。
ブリッジモデムだからか?と思って、ブロードバンドルーターをはさんでみましたが、全く変わらず。
うーむむむむむ…。

もうひとつ気になったのは、システムのプロパティからバージョン情報を見ると「ServicePack 2」との表示があったのに、「プログラムの追加と削除」を見ると、「Windows XP ServicePack 3」の文字が。

「ああ、サービスパック3は入れたはずなんですけどね」

…どうももともとがSP3がうまく適用できてなかったんじゃないか?という気がします。
ウイルス対策ソフトがあると、サービスパックの適用に失敗することはよくある話です。

どうにもパソコン単体でDNS参照ができていない事例がほとんど見つからないですし、サービスパック適用の不具合があったんだとすれば、これはもうリカバリ以外に修正手段はないんじゃないか?
アップデートの不具合は、何が起こっているか見当も付かないので、がんばって治そうとしても無駄に時間がかかるだけ。
引取修理でリカバリをさせていただくことにしました。

作業場で、まずはハードディスクにエラーがないことを確認。
ここでダメだとリカバリは徒労に終わります。
問題ないことを確認して、内蔵のリカバリシステムからリカバリです。
リカバリ自体は1時間ちょっと、SP3のCD-Rでサービスパック適用、さらにWindowsUpdateで更新。

お客様のパソコンは、某メーカー製でPentium4で512MB搭載の、WindowsXP(SP1)プリインストールだったのですが、SP3適用後も、かなり快適に、ビュンビュン動いています。

こんな状態で、「XPはサポート切れなのでVistaか7に買い替えなさい」って言われても…普通の人の感覚では、それはありえないですよね。
マイクロソフトも、ちょっとは売り方を考えて欲しいものです。

リカバリが完了し、お客様宅へ納品です。
ブリッジモデムは、ルーター内蔵モデムに変わってました。
YBBへ連絡した際に、「一応モデムは交換しましょう」と言われたそうです…。
ブリッジモデムでウイルス対策ソフトもなしに直接接続は危なすぎるので、一応ブロードバンドルーターを持ってきたんですが、コレだと必要ないですね。

さて、問題なく接続できて、Yahoo!のトップページもきっちり表示されることを確認して、BBセキュリティのサイトへ。
YBB版ノートンインターネットセキュリティをダウンロード、インストール。

…あっという間に完了してしまいました。プレスキャンも含め、15分もかかってません。
「え?もう終わり?」みたいな。

最初からこうしとけよノートン先生…。

きっかけとなったウォークマンのソフトも問題なくインストール完了、きちんと動くようですので、これで引渡しです。

とりあえず、リカバリから正しい手順でセットアップ・アップデートしてあるので、あらゆる面で快適になりましたので、お客様にはご満足いただけました。

今回は結局リカバリでしたが、DNSの問題はかなりわかりづらい、と改めて痛感です。

ちなみに、人気blogランキング参加中です。 よろしくお願いします。

このエントリーをはてなブックマークに追加 このエントリーを含むはてなブックマーク この記事をクリップ! BuzzurlにブックマークBuzzurlにブックマーク

2009年04月17日(金) 定番トラブル, ソフトウェアアップグレード関連, ソフトウェア不具合関連, ソフトウェア不具合関連(リカバリ), ソフトウェア不具合関連(設定不良), ネットにつながらない・遅い, パソコントラブル, パソコン・インターネット, 日記・コラム・つぶやき |

« それは世間によくある誤解。乾電池編。 | トップページ | またもやStop:0x00000024。今度はierdfgh.exeとセット。 »

定番トラブル」カテゴリの記事

ソフトウェアアップグレード関連」カテゴリの記事

ソフトウェア不具合関連」カテゴリの記事

ソフトウェア不具合関連(リカバリ)」カテゴリの記事

ソフトウェア不具合関連(設定不良)」カテゴリの記事

ネットにつながらない・遅い」カテゴリの記事

パソコントラブル」カテゴリの記事

パソコン・インターネット」カテゴリの記事

日記・コラム・つぶやき」カテゴリの記事

トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/13757/44740625/void
↑トラックバックをいただく際は、最後の「/void」を抜いてください。お手数ですがよろしくお願いいたします。

※あまりにも無関係なトラックバックが多いため、当面はトラックバックの公開は承認制にしました。トラックバックを送っていただいてもすぐには反映されません。ご了承願います。

※トラックバックをいただく際は、この記事のURLを記事中に記載(もしくはリンク挿入)願います。
この記事と無関係な内容であったり、明らかな宣伝もしくは宣伝活動目的と判断されるもの、トラックバック元がトップページへのリンクであるもの、もしくは当方が不適切と判断されたものは、公開の承認はなされません。あらかじめご了承願います。

この記事へのトラックバック一覧です: この「つながらない」は…。:

コメント

毎日拝見しています。
お疲れさまです!

文中にはなかったので…
確認済みと思いますがhostsファイルに追記の痕跡?などは
なかったのでしょうか?
以前,当方はhostsファイルにだいぶ遊ばれたことがありまして(苦笑)
ちょびっと気になったのでコメントしてみました。
的外れでしたらスルーして下さい。

これからもがんばって下さい。
応援してま〜す!

投稿: shinyokodays | 2009/04/23 12:17:20

一昨日、全く同じ症状に遭遇しました。光(ルーター付き)ですが、IPは取れているのに名前解決がダメで、おまけにシステムではXP-SP2なのにプログラムの追加と削除にはSP3があるのも同じでした。

今までDNS未解決はノートン先生かバカフィーが悪戯してたことが多かったですが、今回はバスター侍。但し2006・・・。他に「Symantec SecurityScan」やら「Spybot」やらが入ってたんで一個一個削除してみましたが変わらず。Hostファイルも元のまんま。

結局、不完全SP3も原因かと思い、システム復元をかけたら簡単に治りました。最初からこないしといたら良かったな・・・。

投稿: う~ | 2009/04/23 19:30:06

サービスパックの失敗でたまに見る症状ですね。
一応修復インストールで改善します。

サービスパック適用中に電源切る人に多いきがします。

投稿: レモン茶 | 2009/04/23 23:41:19

shinyokodays さん
ああ、そうでした。書いてませんでしたね。
HostsファイルとLMHostsファイルは確認済みです。
Hostsファイルはデフォルトのまま、LMHostsは「lmhosts.sam」しかない状態。
ここも基本ですよね。いろいろあったので書くのを忘れてました…。

う~ さん
どうもこの「ニセSP3状態」は曲者のようですね。
今後もしばしば見かけることになりそうです…。
システム復元は…なんかあてにならない場合も増えてきました。
復旧できればラッキー、程度に考えてます。

レモン茶 さん

>サービスパック適用中に電源切る人に多いきがします。

そうですね。私もそういう人もいるんじゃないかと思います。
SP3適用にはどう少なく見積もっても20分はかかるはずですから。
シャットダウンで意図せず適用が始まったら、そういうものだと知らない人だと、「切らないでください」と書いてあっても切りたくなりますよね。

修復インストールは…メーカー製だと厳しいんですよねぇ。
よほどの事態でないとできません。

投稿: ささもと | 2009/04/24 4:16:00

以前に同様の症状がありましたがサービス→DNS Clientの再起動で復帰しました。セーフモードや通常の再起動ではDNSがリセットされない場合があるようです。

投稿: TRY | 2009/04/24 12:00:45

TRY さん
ああ、そういえばこれも書いてませんでしたね。
確か…止まってて起動したのにダメだったか、サービス自体がなかったか、どっちかです…記憶があいまいです。ダメだなぁ…。

それにしても、手動でサービスだけを再起動でないとダメだなんて…普通思いませんよねぇ。

投稿: ささもと | 2009/04/24 12:23:03

私も同様の症状を何度か見ています。
すべて、プログラムの追加と削除からSP3をアンインストールして、再度SP3インストールで直りました。

SP3インストールの失敗なんでしょうけど、中途半端な状態で動いてしまうOSに問題ありかもしれませんね。

投稿: oi | 2009/04/25 13:03:28

oi さん
なるほど、それで治ればリカバリよりは早いでしょうから、やってみる価値はありそうですが、それでも1時間はかかりますよね…。
事例が多くあれば検証もできるんですが、なかなかねぇ…。

投稿: ささもと | 2009/04/26 6:08:14

コメントを書く




※Spam対策のため、コメント公開時E-Mailは非表示となります。









※当面コメントは承認後の公開となります

« それは世間によくある誤解。乾電池編。 | トップページ | またもやStop:0x00000024。今度はierdfgh.exeとセット。 »